Troubleshooting HtoA installs


If you have a problem like this:

  • HtoA does not show up in Houdini
  • the HtoA material nodes are missing
  • or you get node type errors such as
    • Failed to match node type definition
    • Error: bad node type found
    • Unknown operator on load

that is almost always because the environment (PATH and HOUDINI_PATH) is not set up correctly for HtoA and Houdini.

First, how to do you start Houdini? Don’t double-click on a hip file, because the Houdini environment won’t be set up correctly.

Second, what’s your houdini.env look like?
You want something like this (PATH is for Windows only):

# htoa config start
PATH = "$PATH;C:/arnold/htoa/htoa-5.6.0.0_r370661f_houdini-18.0.597/htoa-5.6.0.0_r370661f_houdini-${HOUDINI_VERSION}/scripts/bin"
HOUDINI_PATH = "C:/arnold/htoa/htoa-5.6.0.0_r370661f_houdini-18.0.597/htoa-5.6.0.0_r370661f_houdini-${HOUDINI_VERSION};&"
# htoa config end

Third, check Help > About Houdini > Show Details
You want to see the HtoA location at the start of HOUDINI_PATH

If you have other renderers and plugins, I would remove all other plugins from HOUDINI_PATH, get HtoA working, and then put the other stuff back.

If you need more help, please send support your houdini.env file (or json package if that’s what you’re using) and the Houdini info from Show Details.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s